Uploaded image for project: 'NetarchiveSuite'
  1. NetarchiveSuite
  2. NAS-2480

Empty domain crawlertraps are inserted into H3 templates

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.1
    • Fix Version/s: 5.2
    • Component/s: Heritrix 3
    • Labels:
      None
    • Sprint:
      NAS 5.2
    • Verification:
      Hide

      Added a crawlertrap for a domain and verified that message said "Inserting 1 crawlertrap". Also that there were no similar messages for other domains without crawler traps.

      Show
      Added a crawlertrap for a domain and verified that message said "Inserting 1 crawlertrap". Also that there were no similar messages for other domains without crawler traps.

      Description

      When domain-specifJic crawlertraps are inserted, one empty crawltrap line are always inserted giving loglines like this in the log:

      Inserting 1 crawlertraps for domain 'netarkivet.dk' into the template
      

      So we get this line in the resulting template <value></value>

      Could the error be in DomainDBDAO.getCrawlertraps method.
      At least empty lines are not currently removed when read from the database

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                svc Søren Vejrup Carlsen
                Reporter:
                svc Søren Vejrup Carlsen
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: