Colin Rosenthal

Removed debugging funtionality and fixed documentation.

Removed risky space in crawl annotation.

Replaced orderxml with one similar to that in the release test package.

Added heritrix queue name as an annotation in crawl log.

Make sure that "replacement" template in system test uses our NAS queue assignment policy.

Missing placeholder in list to be removed

Quick experiment with adding queuename to crawl log.

Added the two new HaCos to the expected application set

Added timestamp to SystemTest logfile.

Added umbra beans to template uploaded in SystemTest.

typo

Redirect output for debugging

Code Review follow-ups

javadoc

javadoc

remove the comments

remove the comments

fix javadoc

fix javadoc

Actually it doesn't matter. The getHost() method will trim the scheme away anyway. However without the scheme, the "getInstance()" method will die. It might be better to add "dummyscheme://" instea...

Actually it doesn't matter. The getHost() method will trim the scheme away anyway. However without the scheme, the "getInstance()" method will die. It might be better to add "dummyscheme://" instead, to show that the scheme doesn't matter.

But not today.

But not today.

Escaped string values in xml attributes.

Rebuilt complete settings. (again)

Rebuilt complete settings.

Merge branch 'NAS-2794-seeds-without-http' into umbra

Fix to NAS-2794 - correct queue assignment when url scheme is missing

Fix this description

Fix this description

finish javadoc

finish javadoc

remove comment.

remove comment.

Using the new StringJoiner utility makes it easier to build a String separated by newlines. Consider the possibility.

Using the new StringJoiner utility makes it easier to build a String separated by newlines. Consider the possibility.

remove these commented lines.

remove these commented lines.

We should try to make the new placeholders more consistent in their naming. I think they should all start with "UMBRA_" so they are easy to find in the cxml.

We should try to make the new placeholders more consistent in their naming. I think they should all start with "UMBRA_" so they are easy to find in the cxml.

javadoc

javadoc