NetarchiveSuite-Github

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
javadoc

javadoc

remove the comments

remove the comments

fix javadoc

fix javadoc

Actually it doesn't matter. The getHost() method will trim the scheme away anyway. However without the scheme, the "getInstance()" method will die. It might be better to add "dummyscheme://" instea...

Actually it doesn't matter. The getHost() method will trim the scheme away anyway. However without the scheme, the "getInstance()" method will die. It might be better to add "dummyscheme://" instead, to show that the scheme doesn't matter.

But not today.

But not today.

Soon we may have to think of the case, where sites only can be accessed through https://.

Soon we may have to think of the case, where sites only can be accessed through https://.

Why the "1" in the names?

Why the "1" in the names?

What if it has another scheme/tag? Is that possible? (Like ftp:// or something, then wouldn't it become "http://ftp://..."?)

What if it has another scheme/tag? Is that possible? (Like ftp:// or something, then wouldn't it become "http://ftp://..."?)

Fix this description

Fix this description

finish javadoc

finish javadoc

remove comment.

remove comment.

Using the new StringJoiner utility makes it easier to build a String separated by newlines. Consider the possibility.

Using the new StringJoiner utility makes it easier to build a String separated by newlines. Consider the possibility.

remove these commented lines.

remove these commented lines.

We should try to make the new placeholders more consistent in their naming. I think they should all start with "UMBRA_" so they are easy to find in the cxml.

We should try to make the new placeholders more consistent in their naming. I think they should all start with "UMBRA_" so they are easy to find in the cxml.

javadoc

javadoc

tbh, I thought we'd deleted all these classes from the code. Someone should check in master in case Søren did it after this branch was branched.

tbh, I thought we'd deleted all these classes from the code. Someone should check in master in case Søren did it after this branch was branched.

NAS Umbra Integration
NAS Umbra Integration
Review closed

Review closed

The objective above is of course wrong as it stands. To comply with the BNF and legacy naming scheme, we ended up with // Same pattern here as defined in class dk.netarkivet.viewerproxy.webinterf...

The objective above is of course wrong as it stands.
To comply with the BNF and legacy naming scheme, we ended up with

 // Same pattern here as defined in class dk.netarkivet.viewerproxy.webinterface.Reporting
 final String specifiedPattern = "(.*-)?" + id + "(-.*)?" + metadataFilePatternSuffix;
Looks good. The "Objective" listed above was modified to, I assume, to be consistent with both Netarkivet and BnF naming conventions - so an option (.*-) prefix before the id.

Looks good. The "Objective" listed above was modified to, I assume, to be consistent with both Netarkivet and BnF naming conventions - so an option (.*-) prefix before the id.

Closing review. No followup needed

Closing review.
No followup needed

NAS-2760: Remove obsolete heritrix 1 files from distribution
NAS-2760: Remove obsolete heritrix 1 files from distribution
NAS-2712: Indexserver includes too much in the specifiedPattern used by RawMetadataCache#cacheData(Long id)
NAS-2712: Indexserver includes too much in the specifiedPattern used by RawMetadataCache#cacheData(Long id)
I believe this is part of 5.4.2 now, so we might as well close this after a quick review

I believe this is part of 5.4.2 now, so we might as well close this after a quick review